Tuesday, May 14, 2013

Still Using Java 1.5?

Traditionally most Eclipse plugins declare a Java 1.5 compatibility in their bundle manifests:

Bundle-RequiredExecutionEnvironment: J2SE-1.5

And so does CDO. Now it seems that newer versions of some JDBC drivers (e.g. HSQLDB) start to depend on Java 1.6 and, unfortunately, the JDBC API of Java 1.6 is not compatible with its 1.5 pendant.

We're currently discussing how to deal with this problem and we're very interested in your opinion. Please participate in this small poll to give us an impression on whether Java 1.5 support is still needed:

What JRE Are You Using?


  1. Move it up, someone has to start. :-)

  2. Can't the platform specific dependencies be kept in fragments with different required execution environments?

    I voted for 1.6 but I alternate between 1.6 and 1.7 depending on whether I am working on consulting with a client (1.6) or developing my product (1.7).

  3. Btw, JEP 182 - http://openjdk.java.net/jeps/182

    Java 8 is deprecating -source and -target of 1.5 and earlier.

    Java 9 is removing 1.5 entirely.

    The JDK is moving to a "one + three back" policy for the compiler. (how long until the runtime VM does the same?)